Browse Source

Set minimum version for LibUV to 1.0.0

Older versions of libuv did not have the uv_loop_close API.  It first
showed up in unstable releases ~ v0.11.20 but was not available in
a stable release until v1.0
master
Chuck Atkins 5 years ago
committed by Brad King
parent
commit
20e8dcf162
  1. 2
      CMakeLists.txt

2
CMakeLists.txt

@ -491,7 +491,7 @@ int main(void) { return 0; }
if(CMAKE_USE_LIBUV)
if(CMAKE_USE_SYSTEM_LIBUV)
if(NOT CMAKE_VERSION VERSION_LESS 3.0)
find_package(LibUV)
find_package(LibUV 1.0.0)
else()
message(FATAL_ERROR "CMAKE_USE_SYSTEM_LIBUV requires CMake >= 3.0")
endif()

Loading…
Cancel
Save